Go Back   FitDay Discussion Boards > Forum Feedback and Support > FitDay 2.0 Feedback & Support
Search Today's Posts Mark Forums Read


Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 01-03-2013, 06:16 PM   #1 (permalink)
FitDay Member
 
Join Date: May 2010
Posts: 443
Default Forum Thread Truncation Issue

Hi Support, Happy New Year!

I've run across an issue with the forum discussion board. I'm usually a frequent poster to the boards and this is the first time this issue has appeared.

I posted to a thread this morning, but didn't see the post appear, because the second page of posts to the thread was unavailable to me. When I logged out, I could see the the entire thread. Specifically, when I was logged in, the link to the second page was being redirected incorrectly.

The details are:

I visit page one of the thread in the forum 'support group just women' titled '7 Day Motivational Thread for 12/31/12' and I see it appear with the url below:

http://www.fitday.com/fitness/forums...2-31-12-a.html

When I click on page 2 of the link I get redirected back to the link that appears above. The same thing happens when I use the arrow to advance the page - I get redirected back to page one. I can never see page 2 when logged in. Even when I try to mung the url to see page two, I get redirected from [...]thread-12-31-12-a-2.html back to [...]thread-12-31-12-a.html.

If I log out, I can see all the posts in the thread, (with the ads) and never get redirected incorrectly. That is, I can see [...]thread-12-31-12-a-2.html, [...]thread-12-31-12-a-5.html, and all the other pages.

I am a premium member using firefox v. 17.0.1 on a Win-7 OS Dell.

Please let me know if you need more info or help w/ debug.

- Donna Martz

Last edited by dmartz; 01-03-2013 at 06:39 PM.
dmartz is offline   Reply With Quote
Old 01-03-2013, 06:40 PM   #2 (permalink)
FitDay Member
 
Join Date: May 2010
Posts: 443
Default

Issue may be related to caching. Should Cache-Control fields be applied to the response header? There does not appear to be any in the pages I view.
dmartz is offline   Reply With Quote
Old 01-03-2013, 11:24 PM   #3 (permalink)
Super Moderator
 
cjohnson728's Avatar
 
Join Date: Jan 2010
Posts: 4,083
Default

This happened to me a couple times; I cleared out my cache and it was fine.
__________________
Cassie

And now that you don't have to be perfect, you can be good.
-John Steinbeck
cjohnson728 is offline   Reply With Quote
Old 01-04-2013, 12:46 AM   #4 (permalink)
FitDay Member
 
Join Date: May 2010
Posts: 443
Default

Quote:
Originally Posted by cjohnson728 View Post
This happened to me a couple times; I cleared out my cache and it was fine.
Yeah, the developers may want to consider adding the Cache-Control: no-cache, no-store header directive to fitday pages. Might also prevent some stale data calcs I see once in a while.

dmartz is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.3.2